PDA

View Full Version : major steering problem


olly986
2006.08.13, 06:51 PM
hello you all, i am new to your forum (1st thread) and have a serious problem with my 02 steering.
I cannot get the steering to get back to neutral, since I got the car it never worked!

so opened the servo, try to fiddle around (at least opened 10 times now)

tried different radios, crystals (all 27) still not working, the funny thing is even if I use the pod on electronic board, the steering moves right to left, but when I switch the car off, the servo saver is still loaded and the wheels do not come back to neutral either.

any ideas? as I am running out of them myself

I have being racing electric 12, 10, on and off road for a long time so have the basic knowledge of eletronics and car set up

thanks and congrats on a very nice forum

DogbreathRacing
2006.08.14, 12:10 AM
If the pot on the PCB is not holding the setting then chances are you have a bad steering potentiometer in the servo, there are replacements around, takes some simple soldering skills to install, should fix the problem.

olly986
2006.08.14, 04:59 PM
thanks, this was my most obvious reasoning too, but I am still puzzled about why the servo saver is stuck on the left or right when the electrics are off, there is no reason for this, when off the wheels should move freely left to right

CUSTOM
2006.08.20, 09:04 PM
this happend to my MZM: i was driving it real fast and then one of my wheels hit a wall at high speed, pushing the servo saver over the tierod causing the spring in the servosaver to push the tierod to one side; making it imposible to steer. this can be fixed by taking apart the servo and putting the servo-saver in the proper place according to the manual from kyosho. put it back together and it should work.
gook luck!

-Custom

olly986
2006.08.27, 06:25 AM
thanks custom but it is not this either, i took that bloody servo apart so many times now i can rebuild it my eyes closed, a friend has a chassis he is not using anymore so we are going to swap the electronics, we just can't find why it happens.

thanks again

olly986
2006.09.03, 07:39 PM
just to let all know, changed servo and everything is fine now, thanks for your comments and help

ps: still haven't got a clue why it did not work