PDA

View Full Version : Why does my steering do this?


Spoon
2007.02.13, 10:46 PM
Watch the video
http://mini-zracer.com/mini-zgallery/showphoto.php?photo=7575&cat=722&page=1

basically when I return from a right turn the steering overshoots then settles in. This leave my car just a little farther left than I expect it to be. It comes right back to center when I turn left. My AD car and AWD do not do this.

The car is fairly new (<1month) so there shouldn't be any crud in the servo gears. Just to make sure, I opened it up and blasted some compressed air. It looked pretty clean when I opened it up though.

Any thoughts?

jleecov
2007.02.13, 11:27 PM
I have the same problem on one of my cars too. Anyone know how to fix this?

locwan
2007.02.14, 12:21 AM
I had the same problem w/ one of my cars in the past. Found out I had accidently pinched a servo sensor wire when I put the chassis cover on.

Also, a bad sensor might also cause this.

Ninja
2007.02.14, 12:37 AM
I had a similar problem with an 01 a long time ago. It would snap back like that from both directions at full lock. I called it "Backlash" Basically the sensing or signal is delayed some how. One thing to try is backing the d/r down just a tiny bit at a time and see if this helps. On my 01 this worked great and it didnt make a difference in the turning radius. I think it may also have something to do with the un-adjustable end-point setting in the reciever. Higher end radios can be adjusted and dial this out. The d/r has almost the same effect, so I would try that if I dont have a high end radio.

Draconious
2007.02.14, 12:40 AM
Asuming the wires are not broken...
You might want to try this:
http://mini-zracer.com/forums/showthread.php?p=254693#post254693

El Tigre
2007.02.14, 09:16 AM
Sometimes, the problem is not in the car, but in the radio. There is a large Potentiometer behind the steering wheel on the radio, when this wears out or is defective it will cause the car to steer funny. Try a different radio in your troubleshooting.

Spoon
2007.02.14, 09:44 AM
All good thoughts guys, I've done a little more trouble shooting, here are the results so far.

1. It's not the radio. I am using a Helios and I also tried it with a KT5. Happens with both.

2. Still does it with the servo cover off, so I don't think it's a pinched wire.

I suspect that Drac's suggestion is the way to go. I have a temporary fix though.

It works fine if I return the steering slowly (or just don't let go of the wheel for it to recenter) so I turned down the return steering speed on my Helios. It still does it a little bit but not nearly as much. I'll put it back together and see if I can drive it. The next step is to see if I can find some switch lube. I am hoping something like this will do...

http://www2.gpmd.com/image/t/tamr8723.jpg

Draconious
2007.02.14, 09:51 AM
The servo saver may also be binding... if those plastic walls that suport the gears are not in there just right... it binds up.

Maybe some king-pin oil on the servo saver...

MINIz guy11
2007.02.14, 10:57 AM
I had something like that with my 3010 FET car. If I took out the gears, nothing was wrong and everything fits. Then I put it in the car and it does the same thing as your, possibly even worse as it got completely stuck at times. Had to change servo gears to a spare set I had and the problem is fixed.

imxlr8ed
2007.02.14, 12:06 PM
I think Drac's right on about the bar binding. I had this same thing on an 02, filed the bar down and it was fine.

Also... if it's not that, maybe try uncentering the steering using the board, then get it back straight with your controller, see if it still does it. The pot might have a "flat spot" near center.

All else fails... swap the pot.