PDA

View Full Version : Brand new OL not reversing


Rockstar
2008.07.28, 06:59 PM
I JUST bought my G55 Overland today and it doesn't reverse and sometimes it randomly drives forwards or backwards. Whats the deal with this? I just spent almost 200 dollars on something that won't work properly. Any help?

LBRC
2008.07.28, 09:01 PM
Please don’t take this the wrong way, but the number one cause to the problems you are describing is not spending a little quality time with the owner’s manual.

The Overland has a break function the first time you push the throttle forward it applies the breaks, to reverse you let the trigger return to neutral then immediately push the trigger forward a second time.

If it still doesn’t enter reverse:
First verify that the car and TX batteries are good, and that both crystals are for the same channel.

• Then remove the TX tuning panel,
• Turn first the Tx then the car ON
• Turn the car over so that it doesn’t run away
• And rotate the throttle trim fully clockwise, the wheels should spin in reverse
• Then rotate it counter clockwise, the wheels should spin forward
• Rotate it clockwise until the wheels come to a complete stop.

If it works then you know the car is good and that there is a problem with how you are trying to enter reverse. Centering the throttle trim will make it easier to enter reverse.
or
If the wheels will not turn in reverse with the throttle trim fully clockwise (towards the R)then you know that there is a problem with the car in which case you need to contact either Kyosho and/or the dealer you purchased the car from.

As for the random forward/reverse thing; Always turn the Tx on first then the car within range of the Tx, and check for electrical interference by driving in a few different area’s.

BTW I hope you really didn’t spend two hundred for just the Overland, I suppose it depends on where in the world you are at but ouch.

Rockstar
2008.07.28, 09:05 PM
Thanks for the help, I'll try that out :D well the only reason why it cost so much was because he had to order it in for me and then I bought some lock nuts too so that could be why, it only came to 190 :P but thats still alot haha

Rockstar
2008.07.28, 10:05 PM
Sorry for the double post, but I got it working :D all I had to do was adjust the throttle trim and it worked. These things can crawl over some stuff :P

LBRC
2008.07.28, 10:52 PM
Working is good.

Cheers

Rockstar
2008.07.30, 06:21 PM
it's doing the same thing again :mad: and when I adjust the throttle trim it makes no difference. If I move the throttle forward the wheels move forward, I move the throttle back, the wheels move forward. I hope nothing is terribly wrong with it. and the red light on the controller keeps flashing if that helps at all.

Rockstar
2008.08.01, 07:19 PM
Can anyone help me please?

franciscantony
2008.08.01, 07:39 PM
try fresh batteries in the controller.

Rockstar
2008.08.01, 09:05 PM
Do you think it's because I have 4 Energizers and 4 Radioshack batteries?

franciscantony
2008.08.01, 11:38 PM
in my kt5 when the batttery is low it blinks.
I don't think the brands matter.