PDA

View Full Version : atomic knuckle problem


MXMRCR
2009.12.05, 11:10 AM
i just got these atm knuckles and the atm bearings don't even fit over the axle, i have these same knuckles on my MM and they are fine, anyone had this problem or got any solutions...


http://i279.photobucket.com/albums/kk131/optionboy/ATM01.jpg


thanks for looking

MXMRCR
2009.12.05, 11:52 AM
i just got these atm knucles and the atm bearings don't even fit over the axle, i have these same knuckles on my MM and they are fine, anyone had this problem or got any solutions...


http://i279.photobucket.com/albums/kk131/optionboy/ATM01.jpg



thanks for looking

mk2kompressor
2009.12.05, 12:06 PM
yup had the same problem in the past with the older v2 knuckles,had to sand the shaft a little:)

MXMRCR
2009.12.05, 12:07 PM
thanks matt, i'll give it a shot but i don't wanna damage the thread.

mk2kompressor
2009.12.05, 12:10 PM
you shouldnt damage the thread,use 500g wet and dry.
the shaft will just need a tickle:eek:

MXMRCR
2009.12.05, 12:19 PM
okay cool, i'll do it tomorrow and let you if i get them rolling,

thanks again matt.
:)

arch2b
2009.12.05, 01:53 PM
1. please post to an appropriate area. kyosho is not the best place for a discussion on atomic knuckle issues.

2. DO NOT POST THE SAME TOPIC MULTIPLE TIMES.

every brand lets a few bum units out. i've had pn parts that had milling flaws, angled taped holes or holes not tapped. atomic and pn have been more consistent for me than 3racing and gpm.

yes, i've had the same issue with pn knuckles even. it's either shaft tolerances or bearing tolerance issue. i just changed out the bearing and moved on. odd thing is, it's only happened with a couple bearings. maybe 4 out of 12.

you could try polishing the shaft to remove the smallest fraction of material or contact the retailer and or manufacturer for a replacement or refund. no point in keeping a bum part.

MXMRCR
2009.12.06, 11:46 AM
sorry for posting in wrong section,


anyway the wet'n'dry worked perfectly and i did take some 'autosol' polish to bring the shine back (thanks arch2b), problem solved...thanks guys.:D