PDA

View Full Version : Firelap 2.4Ghz?


doug01n
2010.01.31, 09:18 AM
I saw a firlap 2.4Ghz at Miracle Mart, do you guys know it already? Heard about?

http://www.miracle-mart.com/store/images/large/iwaver/IWR052_LRG.jpg

:confused:

wildthing
2010.02.02, 08:50 PM
yup i have 1 unit working... 1 unit I burn the fets (I installed an iwaver pro motor) :)

then another 20 units just arrrived...I have yet to use/evaluate the new batch but the working unit I have seems to be doing well.

Pros:

- Cheap
- Mini-Z compatible (aftermarket parts of mini-Zs is probably 90-100% compatible)
- 2.4Ghz... with similar to Futaba 3PM 2.4Ghz menu and settings.

Cons:

- Cheap plastics - they behave like the old plastic kyosho are made off (unlike the Blue-Gray ones which are harder). The cheap plastics could be prone to breakage when handle improperly.
- Some tx are lemon (lack of quality control perhaps)
- The advertised installed FETS on miracle mart could be good... but those FETs are not the one installed on mine :(

cyberdude
2010.02.11, 09:19 AM
Good to know about the iWaver cons.. i've also placed a PO for 20pcs (minimum purchase) just to try them. i guess i will have to place a PO for 20pcs of Mini-z chassis and some 3010 FETS too..:)

yup i have 1 unit working... 1 unit I burn the fets (I installed an iwaver pro motor) :)

then another 20 units just arrrived...I have yet to use/evaluate the new batch but the working unit I have seems to be doing well.

Pros:

- Cheap
- Mini-Z compatible (aftermarket parts of mini-Zs is probably 90-100% compatible)
- 2.4Ghz... with similar to Futaba 3PM 2.4Ghz menu and settings.

Cons:

- Cheap plastics - they behave like the old plastic kyosho are made off (unlike the Blue-Gray ones which are harder). The cheap plastics could be prone to breakage when handle improperly.
- Some tx are lemon (lack of quality control perhaps)
- The advertised installed FETS on miracle mart could be good... but those FETs are not the one installed on mine :(

murkovics
2010.09.27, 03:53 AM
hay guys i have a few questions! i have a 2.4g nanoracer too but it seems like some problem with it. when i want to start the car by switch it on is only turns on for a half sec than off. the servo shakes a bit than nothing hapens. can u tell me what can be the problem? fets are burn or they have lost the connection? please help me.

wildthing
2010.10.04, 05:23 PM
I think you need to re-bind it. Try a fresh battery too on both tx and car.

If that does not work, try cleaning the PCB. Ho to do that - I usually dismantle the unit (do this carefully). Then I spray the PCB with an electronic contact cleaner (you can get this from most electronic supply stores) and if there are dust/dirt in the board, I also try to use a tooth brush to brush it off while it was soaked with the contact cleaner.

murkovics
2010.11.25, 11:02 AM
thanx for the help! car back in life and under upgrades!! :D any1 tried them with stacked fets? im thinking of 2x2 4562.

wildthing
2011.01.25, 04:42 PM
I just opened one of the six units of Firelap 2.4Ghz I recently got (retails approximately US$90).
http://i23.photobucket.com/albums/b371/2wildthing/Toys/FirelapRTRkit1.jpg

It includes two sets of decals,
http://i23.photobucket.com/albums/b371/2wildthing/Toys/FirelapDecal.jpg

It has a new PCB (compared to those released last year and earlier)
http://i23.photobucket.com/albums/b371/2wildthing/Toys/FirelapPCB.jpg

Uses a "new" MOSFET 4512 spec sheet (http://analogpowerinc.com/datasheet.php?data1=DS_AM4512C_N)
http://i23.photobucket.com/albums/b371/2wildthing/Toys/Mosfet4512.jpg

Chassis is generally like an MR02, so I would assume that it can accomodate all aftemarket parts for MR02 in case you want to upgrade it.
http://i23.photobucket.com/albums/b371/2wildthing/Toys/FirelapChassis.jpg

How does it runs?

Well, base on my preliminary test run after converting it to use 2P lithium ion battery, I need to upgrade to ball bearings and probably even a ball differential to make it run smoother :D

kaden andreas
2011.09.14, 05:53 AM
will these handle a pn 50t motor?
how are these fets compared to 3010's anyone know?

wildthing
2011.09.15, 07:23 AM
Sorry i haven't tried installing any upgraded motors on any of my rentals.

The FET is quite competitive with the 3010s but that is base on a small comparison race between a stock iwaver and a stock mini z mr02 with the 3010s.

Bodom
2011.09.15, 08:03 AM
Sorry i haven't tried installing any upgraded motors on any of my rentals.

The FET is quite competitive with the 3010s but that is base on a small comparison race between a stock iwaver and a stock mini z mr02 with the 3010s.

Isn't the mini-z using a double layer of 3010s ? And the iWaver/Firelap has single layer of 4512Cs

arch2b
2011.09.15, 11:56 AM
thanks for the information and pictures. since fangel? left we have not had any contact from iwaver/firelap. if anyone has the current distributor contact please email/pm it to me. we were in the midst of setting up a purchase order when he left.

wildthing
2011.09.15, 07:48 PM
Last name: Li
First name: Na
Gender: female (can't debug a male or female by name that is chinese)
Email: lina@toylongsun.com
TELL:0086+755+27815600/18926788477
FAX:0086+755+27809945
www.firelap.net

But you can also search them in alibaba.

www.toylongsun.com

kaden andreas
2011.09.23, 08:07 PM
anyone have issues with twitching on the 2.4's under acceleration?

kaden andreas
2011.09.23, 08:48 PM
so i've just did some troubleshooting.
and figured out that the twitching came from my pn50T motor. i switched it to an xspeed motor and still abit of twitch.
i switched back to the stock motor the unit came with and everything was fine.

anyone know how i can use a faster motor without the twitch?

wildthing
2011.09.24, 06:15 AM
Did you put back the pair of 104capacitors on the upgraded motors?

kaden andreas
2011.09.24, 09:22 PM
yup. no go.
still twitching...i read somewhere that an extended asf antenna wire might work???

p.s the xspeeds have caps already and still twitched...

reaper
2011.09.25, 04:50 PM
the 50t may be just on the limit for the board , i guess the "twitch" is because the board carnt supply the power needed for the motor AND run the servo
i have noticed when i run the batterys right down in my iw04 the steering starts to play around

kaden andreas
2011.09.25, 10:40 PM
Has anyone tried faster motors on the 2.4's without twitch?
Or is it my board?

wildthing
2011.09.26, 04:16 PM
Is your firelap AM band or 2.4Ghz?

kaden andreas
2011.09.26, 04:25 PM
I've got the 2.4 2wd.

wildthing
2011.09.26, 07:56 PM
if it is a 2.4ghz, I don't think the Antenna mod will work.

I would like to consider that the MOSFET couldn't handle the power drain thus severely affecting the power distribution to the steering.

If I have time, I'll try the MOSFET MOD and intall a faster motor too.

kaden andreas
2011.09.26, 10:52 PM
Tell me how it Goes.
What motor, if you put power caps, and anything else I mithtve missed.
Cheers

kaden andreas
2011.10.01, 06:14 AM
no updates??
i will try the mosfet mod too and see what happens...

wildthing
2011.10.01, 06:42 AM
Sorry, i was too busy with work lately. If I have time tomorrow, I'll try to upgrade the FETs.