PDA

View Full Version : HELP ! my OL just quit working


X3n0
2010.02.01, 02:38 PM
This morning after putting in freshley charged batteries I fired up my OL. It worked revved up nice and good. Was going to film it on my dining table. Now it wont work. Radio fires up but when I turn on the OL NO TWITCH....batteries are fully charged.....how do I tell if something got fried ? IT is bone stock. No upgrades..

JuniorWKR
2010.02.01, 03:06 PM
Check:
-battery terminals, make sure they arent broken or something is in the way of the battery making contact with the terminal
-all wires, make sure nothing came unconnected at the board
-blown fets, if you look at them and they are bubbled or chard they are blown
-make sure you just didnt lose bind if its 2.4, if am make sure crystals are all the way in and they arent loose

Apie
2010.02.02, 03:54 PM
Bone stock, so no 2.4.

I know its silly but make sure you put the batteries in correctly.

X3n0
2010.02.02, 06:12 PM
well..just an update..I took it apart to check the PCB and no blown fets/loose connection etc...NOW IT WORKS !:confused: