PDA

View Full Version : MR01 Question


tylerb10
2010.12.30, 01:31 PM
Sorry, but the MR01 boards are dead so I came here.

A recent problem developed with my mini z. It has never been abused and is essentially in perfect condition.

All of the sudden while I was racing the car it would no longer respond to a forward input. However it would still go in reverse?

I opened it up and all of the solder joints on the board look fine. To quickly remedy the problem I reversed the wires on the motor and reversed the throttle channel on the TX to enable me to only drive forwards now.

Is this a common problem? Does anyone know a fix for this?


Thanks!

kryten
2010.12.30, 01:49 PM
You could have a blown fet. The small chips on the board next to where the motor wires connect. Check to see if there any any marks or bubbles on them.

tylerb10
2010.12.30, 02:19 PM
I reviewed the PC board with a magnifier glass and I don't see any obvious damage. I noticed at position D1 on the top of the board is a very smallish component that looks a little "worn" but not necessarily damaged...I think.

on the bottom side of the board the FETS (I think) are looking fine. If those are not the FETS (I am not sure what or where the FETS are) but the all the components on the bottom of the board seem to pass a visual inspection.

The steering works fine. We put a volt meter on the PC board where the motor wires attach and they show voltage when transmitting forward but as soon as you transmit reverse, the voltage stops. We tried different controllers too with the same results.

Are there any other ideas?

Thanks for your help.

briankstan
2010.12.30, 02:48 PM
fets can be blown without showing visible damage. if you still have reverse and steering but not forward, chances are it's a fet. it's either gone bad or has gotten hot and maybe one of the legs has lost its solder joint.

you can hit each leg with a hot soldering iron and then see if that fixed it, it not it will need the fets changed.

tylerb10
2010.12.30, 06:38 PM
Is there any way to do a continuity check or anything on the FETS to verify that they are bad before I go through the process of replacing them? And if so how do I do it? Visually they look brand new.


Thanks!

tylerb10
2010.12.30, 08:00 PM
So, we touched each of the FET solder joints to the PCB just to make sure that we didn't have a cold joint and then we went back to the motor wire terminals on the PCB and attached a volt meter. As we gave a forward command on the Tx, the voltage increased to +5.54. Then when reverse was commanded, the voltage went to -5.54. Looks like is should be fixed....

BUT...

We reassembled the car and put in the batteries and gave it a go but guess what? It would only go forward. No reverse! Arrrrgghh!

As soon as we remove the motor wires and touch it with a volt meter we get the +/- readings noted above. what the heck is going on? When the motor was mounted to the PCB we also probed it with the volt meter and we only got + volt reading. No -.

Please advise. I am pulling out my hair and I don't have that much left to lose.

Thanks.

tylerb10
2011.01.01, 03:27 PM
Well, bad news...

I was messing around with it some more with the batteries in and I accidentally must have touched the two motor wires together and a tiny puff of smoke came from the board :(

Now when I give it any throttle the steering freaks out and the motor doesn't turn?

Is there anything I can do now? Would I just have fried the FETS? Or is the entire board dead?

If so where can I get these parts for an MR01? I see that atomic mods has the fets but the board is out of stock and looks like it has been for quite some time.


Thanks for any help you can offer.

herman
2011.01.02, 10:17 PM
hmm... my guess is that you shorted something out...

usually replacing the fets will solve everything... :D

if you know somebody who has done this before, i would suggest seeking his help...

(note: replacing fets are a lot cheaper than replacing hair through implants) :D