PDA

View Full Version : Version 0.64 of Flip Side Racing software available


pinwc4
2011.06.23, 10:30 PM
Version 0.64 of Flip Side Racing software is now available for download. You can get it from the Flip Side Racing software project site (http://www.flipsideracing.org).

There are many changes from version 0.59, check the Release Notes for the details.

As always I welcome any feedback.

ChiMiniRc
2011.06.27, 11:59 PM
• Lap tone while cars add themselves. Great to help us confirm cars register.
• When upgrading, a nice addition would be a prompt stating “New installation will proceed” if it doesn’t find a path for upgrade.
• At no point did I get the issue where starting a race had a slow countdown.
--o Ran 15 races.
• Still seeing slow startups. Running Win7, 32bit, 2.67ghz i7 m620 CPU, 4gb ram, 160gb SSD drive
--o Within 1 second, the DB completed being read (19mb)
--o 50 seconds at “filling race control structure”
--o “Initializing main window” – 30 seconds
--o Lots of time querying QuickTime files
--o Lots of temp files created through the startup process
• Vacuum data base. When I clicked the icon, waited about 5 seconds and then saw “optimizing” for a few seconds.
--o Second time “optimized” appeared within a second of clicking vacuum.
--o I have a fast system. On a slower system I’d feel like I was unsure the vacuum action was triggered. Perhaps a dialog that appears as soon as you start, then changes to “optimizing” ?
• Potential bug
--o I have multiple racers, some that share the same UID. Even though the correct name appears on the race screen, the wrong name appears in statics and export.
--o It would appear that if the database has a unique ID for each racer, the first one for that particular UID is used vs the racer that is active

pinwc4
2011.06.28, 09:50 PM
• Lap tone while cars add themselves. Great to help us confirm cars register.
• When upgrading, a nice addition would be a prompt stating “New installation will proceed” if it doesn’t find a path for upgrade.
• At no point did I get the issue where starting a race had a slow countdown.
--o Ran 15 races.
• Still seeing slow startups. Running Win7, 32bit, 2.67ghz i7 m620 CPU, 4gb ram, 160gb SSD drive
--o Within 1 second, the DB completed being read (19mb)
--o 50 seconds at “filling race control structure”
--o “Initializing main window” – 30 seconds
--o Lots of time querying QuickTime files
--o Lots of temp files created through the startup process
• Vacuum data base. When I clicked the icon, waited about 5 seconds and then saw “optimizing” for a few seconds.
--o Second time “optimized” appeared within a second of clicking vacuum.
--o I have a fast system. On a slower system I’d feel like I was unsure the vacuum action was triggered. Perhaps a dialog that appears as soon as you start, then changes to “optimizing” ?
• Potential bug
--o I have multiple racers, some that share the same UID. Even though the correct name appears on the race screen, the wrong name appears in statics and export.
--o It would appear that if the database has a unique ID for each racer, the first one for that particular UID is used vs the racer that is active

Thanks for your feedback, I greatly appreciate it.

The first thing I need to say is that is a really nice system you have. I am quite jealous. I will have to do some digging to see why startup of the software is so slow on such a nice machine. I have much slower systems and do not experience that. You mention that you see it accessing Quicktime related files, that is strange as I have not compiled the Windows version to use any libraries from Quicktime. Could be a fluke or could be related to the problem.

As for the potential bug I think you are correct. It looks like in some cases it is matching against the first UID in the database. I am not quite sure where or why it is doing that yet but will get it figured out shortly. Internally I most reference a field called the racer id that is independent of both the UID and the name. I had to do this so that duplicate names and duplicate UIDs could exist.

With the database optimization popup that should have occured within a second of clicking the button. I am not able to replicate what you are running into yet, maybe it is platform specific. I finally have my own copy of Windows 7 so I will be able to do more testing on that platform instead of just getting to periodically use it.

pinwc4
2011.06.28, 10:38 PM
• Potential bug
--o I have multiple racers, some that share the same UID. Even though the correct name appears on the race screen, the wrong name appears in statics and export.
--o It would appear that if the database has a unique ID for each racer, the first one for that particular UID is used vs the racer that is active

OK, I have a build that should take care of this problem for future races. You can download the updated exe and libraries from here:

http://www.flipsideracing.org/downloads/FsRaceWin-exe-952.zip

Overwrite the existing files in an existing install of the software with the contents of the above zip file.

I will get a proper build of the software done another day. Right now I am going through installing Windows 7 so I do not have a system to build the full installer for Windows and will probably work on a couple of other things such as the performance issue you encountered etc. before doing a full build anyways.