PDA

View Full Version : Cannot automatically open com port x


ChiMiniRc
2011.11.16, 05:14 PM
Any recommendation on what to try?

I'm helping Hobbytown Orland Park, IL over the phone.

1. XP and confirmed USB serial driver installed.
2. When I-Lap Decoder board is plugged in, device manager added COM 3
3. Software is configured to connect to COM3 and setup for I-Lap


Starting flipside and we get the error "Cannot automatically open Com Port 3".

The decoder board is working as we are seeing the lights blink when transponders go under the bridge.

Any thoughts as to why you'd get the "cannot automatically open com port" error when starting flipside?

I-Lap
2011.11.16, 09:24 PM
We got it working.
Apparently it takes much longer than the usual time for the port to become accessible.

He has a few serious hardware issues in Device Manager, most notably missing drivers for the motherboard chipset. It's a home built PC someone gave him for free. I think once that issue is straightened out it will be normal again.

ChiMiniRc
2011.11.17, 04:32 PM
We got it working.
Apparently it takes much longer than the usual time for the port to become accessible.

He has a few serious hardware issues in Device Manager, most notably missing drivers for the motherboard chipset. It's a home built PC someone gave him for free. I think once that issue is straightened out it will be normal again.

Cool. A new laptop will be in there before the next race on the 26th anyway but I can understand wanting to get something online :)
Glad it ended up working.

pinwc4
2011.11.18, 09:08 AM
I am glad to hear you got it working. I am going to have to remember this, I have not heard of anyone encountering it before but it could be really confusing if you do.

For other people to know the message you were getting should only occur in 2 cases. The first is if the COM port is does not exist yet for programs to use, the second is if the COM port is being used by another program.