PDA

View Full Version : Version 0.76 of Flip Side Racing software released


pinwc4
2011.12.04, 05:47 PM
A new version of Flip Side Racing software has been posted for download on http://www.flipsideracing.org/

This update includes support for the Dirt Champ Design TimeR lap counter (http://www.dirtchampdesign.com)

Additionally I have done some work adding the ability to provide translations for the user interface. If anyone is interested in providing a translation for another language please contact me. I will send you instructions and a file in for you to add the translations for a particular language.

Once I finish up the programming for managing HFAY through the new site I will be focusing more time on enhancing the lap counting software again.

Thanks

Racer-HH
2011.12.06, 02:47 AM
Installed and tested it yesterday for 3 hours of free practice. Everything worked fine as usual on WinXP SP3 with Kyosho IC Tag.

arch2b
2012.01.14, 12:49 PM
Installed this and started missing laps. It ran perfectly fine for a couple hours and then won't got 1 minute without missing laps.

Worth noting that this did not happen until a car with a registered generic transponder began racing. May have no bearing on the situation.

I don't have any files to send as I had to get something working for races today so I had to reinstall the only old version I had on hand which is very old. This one has been working fine with all the cars so it has to be something with .76.

Winxp pro sp1, core and generic transponders.

pinwc4
2012.01.14, 03:46 PM
Installed this and started missing laps. It ran perfectly fine for a couple hours and then won't got 1 minute without missing laps.

Worth noting that this did not happen until a car with a registered generic transponder began racing. May have no bearing on the situation.

I don't have any files to send as I had to get something working for races today so I had to reinstall the only old version I had on hand which is very old. This one has been working fine with all the cars so it has to be something with .76.

Winxp pro sp1, core and generic transponders.

I am sorry to hear that. Probably my only question would be is what version were you using prior to .76? Was it .75? This lets me narrow things down to a small set of changes to check.

Though really I already have my suspicion of the culprit. I made a recent change to the priority for audio giving it a higher priority of processor time than earlier versions. This would mean that the main lap counting functions have a bit less priority. Of course for this to create a problem it would mean that your processor is almost too busy as is and you would have to be running the Core lap counter. The Core lap counter is more sensitive to these things than any of the others and requires much more CPU time. I have a Core as well and have not encountered this, but I have a newer laptop so that probably is why.

The generic transponders do not make a difference. The software has no idea they are not Core. The original Core software had extra logic to figure that out that I do not have.

I will put in some changes for 0.77 to see if it will help. Hoping to release a small update as version 0.77 this weekend anyways.

arch2b
2012.01.14, 04:14 PM
coming up from v.73 running the old copper loop core unit. 7yr old small form factor pc. it's not a power house, thats for sure.

pinwc4
2012.01.15, 05:12 PM
coming up from v.73 running the old copper loop core unit. 7yr old small form factor pc. it's not a power house, thats for sure.

Well if you are interested I have a test build of version 0.77 you can try:

Zip file:
http://www.flipsideracing.org/downloads/fsraceWin-1035.zip

Installer:
http://www.flipsideracing.org/downloads/FlipSideRacing-windows-installer-1035.exe
(http://www.flipsideracing.org/downloads/FlipSideRacing-windows-installer-1035.exe)

It should hopefully correct the problem you encountered.

I have only done minimal testing so far so please let me know how it goes.

Jeremy

arch2b
2012.01.15, 05:13 PM
thanks, we race again on the 22nd and will give this a try and report back.

Racer-HH
2012.02.12, 07:00 AM
Just tested the email function. It seems that the report is sent in html, right? With Outlook and my mobile mail app the content of the email is unreadable as it is displayed as code. What can I do to solve this?

arch2b
2012.02.12, 08:54 AM
still haven't gotten to testing .77 i had it on a thumb drive that i had misplaced and was returned yesterday so now i'm not getting back to the track till march.

pinwc4
2012.02.12, 10:56 AM
Just tested the email function. It seems that the report is sent in html, right? With Outlook and my mobile mail app the content of the email is unreadable as it is displayed as code. What can I do to solve this?

That is correct, it is sending an HTML formatted email, it is essentially sending the html report that can also be viewed using the View Report button. I am surprised that it is unreadable though, it appears fine on my Outlook (both 2007 and 2010) along with some iPhones and Android phones I tested. What device are you using to read the message maybe I can figure something out?

I doubt people would want this information in plain text, without formatting it would be be a mess of data.

pinwc4
2012.02.12, 10:57 AM
still haven't gotten to testing .77 i had it on a thumb drive that i had misplaced and was returned yesterday so now i'm not getting back to the track till march.

Thanks for letting me know.

Most likely I will have another build before then so you might check out for that before installing .77

Racer-HH
2012.02.12, 12:48 PM
I send via gmail. With Outlook 2007 it looks like unformatted html. Smartphone is a Samsung Galaxy S+ with Android 2.3.6 and GMX App.
If you like I can forward you the email.

pinwc4
2012.02.12, 09:05 PM
I send via gmail. With Outlook 2007 it looks like unformatted html. Smartphone is a Samsung Galaxy S+ with Android 2.3.6 and GMX App.
If you like I can forward you the email.

Can you forward me one of those emails. My email address is my name here @flipsidehobbies.com

Also if you have a chance send me the race.xsl file in your reports directory. This controls the format of the reports.

Thanks