PDA

View Full Version : Perfex kt-18 not binding


tokeco
2012.10.14, 05:07 PM
I have a total of three KT-18 remotes and one of them seems to be acting funny!!!

Issue:
When following the procedure to Bind with any 2.4GH Mini-Z, the car fails to recognise the remote... How can I tell? Well, there is a red solid light that turns on during the binding process in the car, however as soon as I stop pressing the bind button on the car the light dims and does not stay bright, hence meaning it didn't recognize the remote...

The remote seems to be ok as it shows the blue dim light for binding, after pressing the throttle (P) and power, but the car doesn't recognise it. I have tried with other mini-Z and none of them work with this particular remote, they work fine with the other remotes.

Any Ideas? :)

I live in Bogota Colombia and obviously sending it back and having it serviced is not really an option.

Thanks,

Camilo

cowboysir
2012.10.15, 12:14 AM
I know it may sound stupid but have you tried changing the batteries in the KT-18?

tokeco
2012.10.15, 08:04 PM
I have.. Sometimes the simplest solution is the fix, but not the batteries.

tofusan
2012.11.22, 03:02 AM
http://mini-zracer.com/forums/showthread.php?t=37668&page=2
Try this
I have successful fix one of my KT-18 by using this solution.