PDA

View Full Version : help with a 2.4 board


assideways
2012.10.31, 10:15 PM
Hi guys, need some help please. In preface i gotta say that my knowledge of electronics/wiring is very limited. I'm trying to convert one of my cars to a 2.4 system. I purchased a used mr02 with a 2.4 board in order to be swapped into one of my other cars. I tested the mr02 and it DID run just fine.

While swapping the board over, a tiny electronic component fell off the board as though it was barely attached. I dont know if it was my error, or if the used car was slightly damaged, but long story short, the board now is missing this piece. I dont know what it is, and what it's function is. It normally resides right between the two motor wire attachement points.

My question is, could the component just be soldered back on? Does it matter in which "direction" it's re-installed?

Please take it easy on me, like i said, i'm a noob when it comes to this stuff. I'm pretty good at soldering, but identifying components is what I need help with. Thanks in advance!

http://farm9.staticflickr.com/8183/8143390932_4872f8e61c_b.jpg
http://farm9.staticflickr.com/8188/8140230215_511cc08998_h.jpg

Rune
2012.11.01, 04:18 AM
Solder it back on. Should work.

Its a non directional capacitor.

assideways
2012.11.01, 08:10 AM
Thanks Rune.

Tried soldering the piece back on, no luck. The LED lights up when the car is powered up, steering works, but once throttle is applied, the LED dims and dies. After that there's no response at all - no steering either. Once I reset the batteries by taking one out and putting it back in, the board comes back to life.

Wondering if part of the board is fried, or if it's just the capacitor that's gone bad. Any idea where I could get a replacement capacitor like that one?

imxlr8ed
2012.11.01, 11:03 AM
That's really weird... the light dims down? Usually when it frys it just goes up in smoke! I damaged this once on one of my boards too and I never got it back to life either. I screwed the old style motor tabs down and I think it cracked the thing off, seemed like it damaged the tiny little pads for that capacitor as well. I never messed with the thing after that.

Sounds like a weak solder joint to me, I would think if it was a short the fets would've sizzled at that first full throttle application.

assideways
2012.11.01, 11:14 AM
i'll try to re-solder the capacitor, or maybe try some wire glue instead since it's such a small area to work with. Could the capacitor itself be fried?

with a fried FET, would there still be steering or a lit LED? :confused:

thanks again!

imxlr8ed
2012.11.01, 06:35 PM
I know you can have steering and no power to the motor, I've also had the light, and have been apparently able to bind with no fet output as well.

I've never heard of your situation before. I'm curious, do you have a motor hooked up when you first hit the throttle, and does it spin at all as the light goes dead?

I wouldn't push it too much though, and try to run half drained cells when testing and soldering... I've found that it's a bit safer to test with cells that are juiced just enough to make sure that everything is working.

These boards can get dicey when running an iron on them, the runs in the board itself are so much more delicate than what they were in the AMs.

assideways
2012.11.01, 07:49 PM
well, what happened prior to my attempt to re-solder was when there was no motor connected, the steering would work and when i hit the throttle, the board would NOT die. once i would connect a motor, and hit the throttle (in noob mode - flashing LED on the controller) there would be no response from the motor, and the LED on the board would die and there would be no response at all, until i would reset the batteries.

Now that I have re-re-soldered the capacitor, the board no longer dies with the motor connected when i hit the throttle, although there's no response from the motor. I tried this with two motors.

any ideas?

imxlr8ed
2012.11.01, 10:36 PM
I was gonna say tor try another motor, you got that covered. Do you think that capacitor melted off or snapped off? Even so, I don't think that would cause your issue if the pad is cracked where the capacitor mounts to. I'm sure you have it bridged with solder by now too. I'd check all the little resistors on the board and maybe give the fets a quick tap down with a hot iron to make sure they're all seated right.

If it still don't get going, maybe try a fet swap? If you can solder that little cap down, I'm sure you could manage a fet swap. Removing the fets without damaging the pads seems to be the toughest part of that job. I've seen some get some micro-sized snips in there and just clip them off carefully before adding the new fets.

If possible, maybe you could try another controller? I doubt that's it but when you get to this point, you begin to try anything and everything!

Hope it's fixable! Best of luck!

Rune
2012.11.02, 06:55 AM
Strange problem.
I agree with the above posters.
If you have a microscope or access to one, inspect the pads and leads on the board.
Check the FET solder joints. A quick dab on all solders can do the trick.
Also try with a motor you absolutely know are ok. Test the motor with one aaa cell to see if it starts and runs freely on this without any hesitation.

Inspect the capacitor. If it has a crack it is most probably gone.
I can measure one to see if I can find the value on it during the weekend.
Sourcing one should be no problem.
Voltage are not important as long as its high enough. The capacitance are what we need to know to find a replacement.

One more thing. Check all the connections on your chassis. Are the terminal leads attached properly?

assideways
2012.11.13, 10:44 AM
Thanks a million for all the help guys!

I ended up pretty much re-doing the whole board, going through all the connections and re-soldering that little piece. All is good and the car is now fully operational! :D

Thanks again for all the detailed explanations and help!