PDA

View Full Version : Loss of drive on MR03S


flashdaniels
2014.03.15, 09:08 AM
So I disconnected my stock motor and stock motor mount to install the underfloor re-inforcement plate on my MR03S. When I re connected everything I lost the drive. I thought I connected my motor the same way it came off but something has gone wrong. Any ideas what this could be?

arch2b
2014.03.15, 09:24 AM
do you have steering and no motor or nothing?

flashdaniels
2014.03.15, 09:26 AM
yes the steering is working fine but I have nothing on the motor

arch2b
2014.03.15, 09:44 AM
possibly burnt fets? i don't recall the fet install on the sports series boards, are they all on the bottom?

flashdaniels
2014.03.15, 09:55 AM
The car was driving no problem before. All I did was unscrew the motor connection wires and then screw them back. Could the fets burn out from just this? I put them back on with the black wire on negative and red for positive and with the solder joints facing up. I thought this is how they came off but im not 100% sure. This is right?

arch2b
2014.03.15, 10:10 AM
there is a tiny board component between the points and a ringlet could have touched a fet leg but i don't think the fets are on top of the board. if you have anyone at a club/store local with experience ask them to take a look at it for confirmation.

fets are a cheap fix as they cost $1+/- each. finding the skilled labor to replace them is the hard part.

cowboysir
2014.03.15, 10:48 AM
Are your motor screws tight enough? I realize it might be a stupid question but it's been known to happen to me...

flashdaniels
2014.03.15, 11:01 AM
How can I check for burnt fets? will they look any different? ie burnt. Is this likely to be a problem with the board? because the car is quite new and I haven't ran it that much and when it has been run its not for a long time. I thought fet burns came from excessive power or long runs on the motor. All I did was unscrew and then re screw the eyelets. I can see a little component on the board in between the two connections but it doesn't look damaged.

flashdaniels
2014.03.15, 11:02 AM
yes I tighten the screws enough I think. to the point where it is all secure and there is no movement on the eyelets.

mleemor60
2014.03.15, 12:12 PM
Viewing the main chassis from the rear you will notice two very small(00)Phillips screws. One on each side of the chassis where the board connects to the chassis. Make sure that those are tight as well. If the car has steering but no motor drive then this isn't the issue but bares checking anyway.

arch2b
2014.03.15, 12:31 PM
I haven't looked recently but there should be threads on burnt fets with pictures describing what they look like.

There have been reports of sports series fets frying as a result of single layer vs the now standard top and bottom layers. It's not uncommon really. You generally have 2 options though, contact Kyosho USA for warranty repair or have a local look at it and replace the fets if needed.

I normally replace fets right out if the box unless I need to keep them stock for rules. I've had horrible luck with burning fets so many times I lost count.

flashdaniels
2014.03.15, 01:17 PM
well it seems like it is showing all the signs of a fet burn. but I still don't understand how this could of happened without running the motor. can they burn out with just the current of the batteries when I turn on the car? surely this can't be enough to burn the fets and if so that is a massive design fault. I live in Europe so I guess kyosho America won't be able to help me in regards to the warranty. Who do I contact in Europe in regards to a warranty? there is no mention of a warranty in the original box or paper work I got with the car.

LED
2014.03.15, 01:51 PM
When you make a short they will burn out. You have tried to run the motor so that can be enough to burn them. Even without the motor spinning, beacause offcourse there is a short so it will not turn. Take the board out, look at them. You will see a little burned spot on them. Or smell them.

TheSteve
2014.03.15, 02:23 PM
Were batteries installed in the car when you removed the motor?

I haven't looked into how a sport series car is wired, on the mr02/mr03 the power switch cuts all power to the board. In the mr03ve power is live to the fets at all times when batteries are installed, only a portion of the electronics is turned on/off by the switch. The mr03ve is a more efficient design but also easier to damage, it is possible the sport series is wired the same way.

It is also possible it was caused by static shock, although something so small with no other wiring attached to it rarely dies from static.


To those that have blown fets repeatedly, gotta see what you're doing, it isn't normal. :)

flashdaniels
2014.03.15, 03:35 PM
So here are my fets. Are they burnt? they look ok to me.

Traveler
2014.03.15, 05:28 PM
FETs look ok to me but not sure what that white goop is in one of those pictures.

Is your gear mesh too tight by any chance?

TheSteve
2014.03.15, 05:44 PM
The fets look fine in the pictures, however they don't always show any physical signs of damage when they die. I assume reverse is also not working? Forward and reverse use different fets so while one direction can die the other will often still work. How do the wires look that are crimped to the eyelets, have you wiggled everything while applying throttle to see if something is intermittent?

flashdaniels
2014.03.15, 06:07 PM
I have zero power going to the motor in forward or reverse. The wire connected to the eyelets look fine to me (same as when they came out of box new) and I have tried putting them back loose, tight, upside down and still nothing. I even tried hooking up a motor from my MR02 and again no joy. When I took them off the first time (to install my re-inforcement plate) I had the batteries out and didn't put batteries back in until the motor wires were back in place. Im no expert in rc cars but I was trying to be as careful as possible to put everything back were it came from! As for the white stuff seems to be a sort of glue which is covering a small roll of what looks like copper wiring. the same glue type stuff is on the connection of the antennae so I assumed it was supposed to be there. The gear mesh is the same as it was when it was new out of the box and like I said before the car was running fine before I took the motor off.

arch2b
2014.03.15, 08:15 PM
search for your EU kyosho site and customer support for a warranty repair.

Geo-Z
2014.03.17, 10:59 AM
flashdaniels I'm bummed to know this has happened to you, mate. When it happens to a new mini-z at our shop it's usually caused by the motor wires not being screwed down to the PCB securely as many others here have pointed out.

Also, a motor wire that's hanging by a thread could look flawless until the car's been turned on. Gently (and i do mean gently) wiggle/ crimp the motor wires in random directions while placing your 03 on a cigarette box so that the rear wheels hang loose. Press down on the throttle and listen/look for signs that the motor is coming to life. This'll help you determine if it's a shoddy wire/solder job on the motor itself.

At our shop I also happened to come across something like this just as a customer was busy setting up his recently opened MR03 sports. He'd just taken it out of the box. We got as far as inserting batteries into the TX and the car and for some bizarre reason his throttle was dead.

Your case is similar but not completely the same as you had a functional throttle from the get-go.

Anyhow what I did was I put on another motor (an x-speed of mine) and pulled the trigger. Nothing.

Then I took the stock motor that wasn't working out of the box and pressed the motor tabs on the ends of the wires to the positive and negative ends of a single AAA battery. It started to spin so the the motor was actually working.

Then I hooked this motor back up to the MR03s. It worked. Odd. Talk about temperamental. :rolleyes:

imxlr8ed
2014.03.17, 04:07 PM
Our LHS is just starting to fire up their rental FHS cars... I can't think if of a better test scenario so I will update as soon as we get "data".

I've already fetted one of these, hopefully that was a freak occurence.

flashdaniels
2014.03.17, 04:07 PM
temperamental is the word! After testing my motor and seeing that it was working just fine I tried connecting back on to my car and its working again! I don't understand because I did nothing!
anyway im happy and rolling again, thanks for all the help guys!

imxlr8ed
2014.03.18, 12:19 AM
I wonder if the factory solder job is hot enough? Sounds like a bad fet connection that only makes contact when you torque on the motor screws. I had a car do this years back. I tapped the back of the fet with the iron and it cleared up. Before that, it would only get power to the motor when the screws were down real tight.

The FHS I fetted was clearly fried, had a perfect blister on the one fet.