PDA

View Full Version : ZRound Suite 1.14 build 04


zround
2015.11.29, 04:27 PM
ZRound Suite 1.14 build 04 available.

Test the new "Lap time target" feature, awesome.

Details on http://zround.com/news.php?extend.84

arch2b
2015.12.07, 01:23 PM
where can we download this?

zround
2015.12.07, 07:30 PM
where can we download this?

Direct link for latest release: http://zround.com/request.php?48

It is now build 05 with minor bugs solved and changes to voice manager for better compatibility with SAPI engines.

arch2b
2016.04.17, 05:50 PM
setting up another PC for zround, this build, with windows vista home premium. when opening, i get an error: error loading sound from file. i have to click OK eleven times before it will continue opening. upon closing the program i get the following error: OLE error 8004503A

i haven't tested this with the hardware yet, looking to resolve these issues first.

zround
2016.04.21, 05:18 PM
setting up another PC for zround, this build, with windows vista home premium. when opening, i get an error: error loading sound from file. i have to click OK eleven times before it will continue opening. upon closing the program i get the following error: OLE error 8004503A

i haven't tested this with the hardware yet, looking to resolve these issues first.

The "error loading sound from file ..." is thrown when the specified sound file doesn't exist or it couldn't be loaded into memory (sounds are cached for better performance) for whatever reason.

Please check the sounds defined into the "Sounds" configuration page are OK.

arch2b
2016.04.21, 06:04 PM
i get the following when testing the sounds; access violation at address 0055DB70 in module 'zrounde.wexe' read address 00000004.

zround
2016.04.22, 11:29 AM
i get the following when testing the sounds; access violation at address 0055DB70 in module 'zrounde.wexe' read address 00000004.

The OLE Error points to Text To Speech engine. On Dec/2015 an issue was reported in Win7/32 (http://zround.com/support/view.php?id=10). It is not a software bug but some kind of environment issue.

ZRound generates a sound cache for numbers in order to enable to play positions while other sounds /text are played. Your issue could be related to this sound files generation.

If you don't have enabled SAPI then we can discard this explanation :-(. Do you have it enabled? If you do, could you please disable it and test?

arch2b
2016.05.13, 06:40 PM
tested and get this OLE error only with version 1.14.4 and higher.

installed 1.15.1 today on a PC with fresh windows 10 install and running into the exact same messages at startup and close. :confused: different computer, different OS, same results.

zround
2016.05.17, 05:09 PM
Ouch!. There is a new option related to sound from 1.14.4 (best lap target) but it shouldn't raise an OLE Error. I have tested on W7/W8/W8.1/W10 and I cannot reproduce the issue.

I will send you a patch with extra debug info. I hope to collect enough information to solve the issue.

Regards.

zround
2016.05.19, 06:12 PM
Please download this patch and unpack the file into the ZRound program group directory.

Then just open ZRoundDebug.exe for testing. It includes a lot of log lines and exception control loading sounds.

http://www.zround.com/files/ZRoundDebug.zip

Regards.

arch2b
2016.05.19, 06:57 PM
downloaded, copied to program files folder for zround and attempted to extract all however it however it stated it was not able to make the subfolder necessary. i made the folder and continued the extract. ran the debug exe and got the following messages:
zrounddebug.exe-system error
the program can not start because gzeventu.dll is missing is missing from your computer. try reinstalling the program to fix this problem.

zrounddebug.exe-system error
the program can not start because SLABHIDtoUART.dll is missing is missing from your computer. try reinstalling the program to fix this problem.

zrounddebug.exe-system error
the program can not start because gzevent.dll is missing is missing from your computer. try reinstalling the program to fix this problem.

zrounddebug.exe-system error
the program can not start because inpout32.dll is missing is missing from your computer. try reinstalling the program to fix this problem.

it does not open.

zround
2016.05.20, 07:48 PM
It is not a full installer but only the binary with extended log. You must copy the .exe file into your ZRound installation path. Usually c:\program files (x86)\zround.

arch2b
2016.05.20, 08:43 PM
yep, moved zip file to c:/program files x86/zround. this is where i have it. it asked to be extracted into a new folder within here named ZRoundDebug. the extraction process could not create the folder so i did and it extracted the files to this location. c:/program files x86/zround/ZRoundDebug

arch2b
2016.05.20, 08:47 PM
just in case the extraction folder was not correct despite being what it asked for, i copied the .exe to the main zround folder and when opening the exe it gets the exact same messages on open and close.

let me know if you want to do a Teamviewer session to remote in and look around yourself.

zround
2016.05.22, 02:02 PM
I'm sorry, we have hosted a miniz event this weekend and I haven't had time to see this. I will create an installer for this debug version asap.

zround
2016.05.23, 02:47 PM
Installer available at http://www.zround.com/files/Setup ZRound Suite 1.15 Build 02rc.exe

arch2b
2016.05.26, 01:18 PM
apologies, i'll get this downloaded and installed tonight.