PDA

View Full Version : Burnt my 2.4 module for helios ex-10


Jace1283
2016.01.27, 02:39 PM
hello, despite my efforts to not reverse the voltage installing lipo on my helios ex-10, i did it anyway! I have fixed the battery problem but i burnt a component on my 2.4 mini-z module. If anyone has repaired one before please let me know where you found the replacement component. The part that blows is a 7mm long black rectangle(soldered on the board) that has a white bar at one end and the number "47" and "20V" on it...thanks

cowboysir
2016.01.27, 08:14 PM
https://www.pridmore.com/Capacitors-Tantalum/CAP-TANT-SMD-47UF-20V-20-7343-31.html

Pretty sure that's what you're describing.

briankstan
2016.01.27, 09:30 PM
hello, despite my efforts to not reverse the voltage installing lipo on my helios ex-10, i did it anyway! I have fixed the battery problem but i burnt a component on my 2.4 mini-z module. If anyone has repaired one before please let me know where you found the replacement component. The part that blows is a 7mm long black rectangle(soldered on the board) that has a white bar at one end and the number "47" and "20V" on it...thanks

I did this exact thing to mine, managed to fix it no problem. I'll see if I can find the info. I have a thread here somewhere.

briankstan
2016.01.27, 09:34 PM
here it is, http://mini-zracer.com/forums/showthread.php?t=33510

you can find the pats locally for a few bucks if you have and electronics store close by.

good luck.

Mike Keely
2016.01.28, 09:54 PM
I had to send two of mine to KO America to be fixed. They told me to stop the charge on the lipo pack at 12 volts. if it goes much higher then 12 volts it will blow some of the components inside the radio or in the module.

Jace1283
2016.02.06, 04:46 PM
Thanks for the responses guys, I got in contact with ko USA and prices seem good for repair, I need a new pot in a Helios anyway.

briankstan
2016.02.12, 08:48 AM
Funny (Not Really :eek: ), we had this exact thing happen to one of our racers Modules last night, plugged in the lipo wrong. I dug though my parts and was able to get his module fixed up and working. :D