Mini-Z, Kyosho Mini-Z Racer, MR-03, MR-02, MA-010, Forums, News, Pictures, Parts, and Shop - Mini-ZRacer.com
Forums, Mini-Z, MiniZ, Kyosho Mini-Z, Kyosho MiniZ, Kyosho Mini-Z Racer
Mini-Z Hop-Ups, Mini-Z Parts, MiniZ Hop-Ups, MiniZ Parts, Kyosho Mini-Z Hop-Ups, Kyosho Mini-Z Parts, Kyosho MiniZ Hop-Ups, Kyosho MiniZ Parts, Kyosho Mini-Z Racer Hop-Ups, Racer Kyosho Mini-Z Parts
Old 2008.07.19, 08:44 PM   #1
TheRinger
THATS HOW I ROLL
 
TheRinger's Avatar
 
Join Date: Dec 2006
Location: Spotsylvania VA
Posts: 1,128
FET installing problem

I did a fet stack on my mr02 am board and have no foward or reverse. I did resistance test on input and output sides, output 2 motor lead, and input side of the fet 2 output side of the fet. I also tested 4 voltage at the motor leads and have no voltage. Please try 2 bear with me 4 I am of coarse no solder or PCB expert. It was a 2x3 stack of 8962's. I then removed one fet layer at a time with no change. When I got 2 the bottom layer from removing the top 2 layers, excess solder from removing the top layer of fets got on the bottom layer and connected the input legs together. After messing with this all night and morning trying 2 figure out what I did wrong I got a little upset and left the input legs on that fet soldered together and power it up 2 see if it would pop a fet 2 make sure that the board is getting power 2 the fets and sure enough it pop the fet I purposely left solder on the input legs. I followed the atomic mods video with the exception of a static wrist strap. I used a radio shack soldering station that I found out that is not grounded and that U shouldn't use a solder station that isn't grounded or at least that is what I heard. Of coarse I've used it 2 practice removing and installing fets on a junk board and it worked. In the process of installing the fets I dropped them on the floor which is carpet and I'm thinking they got zapped then. I am in the process of tracking down a ESD safe solder station and got a static mat with wrist strap 4 the next attempt at fet stacking. Please help.
TheRinger is offline   Reply With Quote
Old 2008.07.19, 10:59 PM   #2
imxlr8ed
Registered User
 
imxlr8ed's Avatar
 
Join Date: Sep 2004
Location: Reading Pa.
Posts: 4,121
We have had a similar situation with those fets here at our club... I think those fets just hate to be stacked. I know that sounds dumb, but long story short... since I've gone back to using 4562s and 7317s for all my fet jobs, I haven't had to make any repairs to anything in a long while. Guess I just trust what I know now even more after dealing with so many oddball fet issues last year.

Then again, I'm still not sold on the whole static thing killing these little guys, I could be wrong though but I'm pretty sure that's never been the issue for my past 3010 nightmares. I've used previously installed fets that have been free bouncing around in my pit box for over a year already and they worked fine.

I guess my new slogan is... 4562s... the most trusted numbers in mosfets!
__________________
My Online Design Studio and Shop!

http://www.shapeways.com/shops/UID

http://www.howfastareyou.com

SUPPORT LBR!!!
(Local Basement Racing)

Last edited by imxlr8ed; 2008.07.19 at 11:03 PM.
imxlr8ed is offline   Reply With Quote
Old 2008.07.20, 12:02 AM   #3
TheRinger
THATS HOW I ROLL
 
TheRinger's Avatar
 
Join Date: Dec 2006
Location: Spotsylvania VA
Posts: 1,128
Well as cheap as 8962 fets are I guess I got what I paid 4. I forgot 2 mention that the 3010's I took off the board I put them back on and they didn't work. Well its good 2 know that I'm not the only 1 that had problems with the 8962's. I also dropped the 3010's on the carpet floor, but yeah I'm not sold on static zapping fets but I can't explain what it is. I went ahead and bit the bullet and bought 6 4562 fets and a hakko soldering station from the shop. The station as far as I can tell is ESD safe. If this doesn't work I guess I can always set them on fire. I should of bought 4562's 2 begin with but since it was my first attempt at fet stacking I thought it would be better 2 try with the cheapest price fets first but thats what I get 4 thinking. Thanks 4 the help imxlr8ed. Hopefully I'll get it right this time.
TheRinger is offline   Reply With Quote
Old 2008.07.20, 09:00 AM   #4
imxlr8ed
Registered User
 
imxlr8ed's Avatar
 
Join Date: Sep 2004
Location: Reading Pa.
Posts: 4,121
Might want to check your power switch wires, and all your leads to the board. Also... might want to think about removing the board entirely and testing out of the car. RadioShack sells the 4 AAA trays with their own power switch... I usually get some of their little alligator clips to hook them up directly to the lead wires. Also, get a stock motor and hook up some alligator clips to that as well so you can hook it up to the board without using screws. I usually power up all of my boards to test them before they go back into the car, trick is to make sure none of the wires are touching when you power up. On my test motor, I have my motor clips glued together (yes... hotglue, love the stuff) so that they cannot touch when they're clipped onto on the board. Make sure the power is off on the tray, put in the crystal, turn on your controller, make sure your antenna wire isn't touching anything and I usually hold the board gently before I throw the main power on the tray... the motor may start throttling and can cause the board to twist over which can cause wires to touch (bad).

it's an easy way to test boards out of the car without having to deal with all of the install details, just make sure you have plenty of distance between those power leads, and nothing is touching or shorting. It sounds a bit scary but after you do it once, you'll see how easy it really can be.

I'll try to post a picture of how I do this today... have to go down and get ready for our first round of HFAY today!
__________________
My Online Design Studio and Shop!

http://www.shapeways.com/shops/UID

http://www.howfastareyou.com

SUPPORT LBR!!!
(Local Basement Racing)
imxlr8ed is offline   Reply With Quote
Old 2008.07.20, 11:50 PM   #5
imxlr8ed
Registered User
 
imxlr8ed's Avatar
 
Join Date: Sep 2004
Location: Reading Pa.
Posts: 4,121
Here's the pics of my typical test setup... not rocket science here, but it works great. Would be cool if one of the aftermarket manufacturers out there would make some kind of clip-in test stand/service station like this for boards, but maybe have all of it built in, and a place to drop in a full servo assembly... I think the demand would be very low though. Just an idea... feel free to steal!

Oh yeah... the trusty fly-tie/solder station pic too...
Attached Images
File Type: jpg test rig.jpg (474.6 KB, 71 views)
File Type: jpg motor clip.jpg (431.5 KB, 59 views)
File Type: jpg iron stand.jpg (421.6 KB, 61 views)
__________________
My Online Design Studio and Shop!

http://www.shapeways.com/shops/UID

http://www.howfastareyou.com

SUPPORT LBR!!!
(Local Basement Racing)

Last edited by imxlr8ed; 2008.07.20 at 11:53 PM.
imxlr8ed is offline   Reply With Quote
Old 2008.07.25, 08:49 PM   #6
TheRinger
THATS HOW I ROLL
 
TheRinger's Avatar
 
Join Date: Dec 2006
Location: Spotsylvania VA
Posts: 1,128
Yeah I also have some homemade tools 2 test the board outside of the car. Radio shack alligator clip test leads and I use a busted monster chassis as a power supply. The board gets power and the steering works but no throttle. I never put the car back together since I did the attempted fet stack. Its in a zip lock bag in pieces awaiting 2 have the 4562 fets I just got from the shop installed but the hakko soldering station I also got from the shop came with the wrong iron so it will be another few weeks before I try 2 install the new fets. I just don't think I can trust my old radio shack solder station. The 1 question I have is my radio shack soldering station has a plug in the back that is 4 a ground. Would that ground the station and iron or just the station?
TheRinger is offline   Reply With Quote
Old 2008.07.26, 01:16 PM   #7
imxlr8ed
Registered User
 
imxlr8ed's Avatar
 
Join Date: Sep 2004
Location: Reading Pa.
Posts: 4,121
I never thought about that one before, I would guess it would keep the iron grounded and keep it on the same field as what you're working on... but once you pick it up, the fields would change anyways. Maybe if there was a strap from the iron to the stand as it was in operation? (not sure if that would work or not really)
__________________
My Online Design Studio and Shop!

http://www.shapeways.com/shops/UID

http://www.howfastareyou.com

SUPPORT LBR!!!
(Local Basement Racing)

Last edited by imxlr8ed; 2008.07.28 at 09:47 AM.
imxlr8ed is offline   Reply With Quote
Old 2008.07.27, 08:13 PM   #8
Old Crow
Old Crow Racing
 
Old Crow's Avatar
 
Join Date: Sep 2004
Location: N.E. Pennsylvania
Posts: 617
Hey! that's my board! How's that going anyway?
Old Crow is offline   Reply With Quote
Old 2008.07.28, 09:48 AM   #9
imxlr8ed
Registered User
 
imxlr8ed's Avatar
 
Join Date: Sep 2004
Location: Reading Pa.
Posts: 4,121
I think there is another place where that lead needs to connect, I have some serious jumping to do on it. I also have to get a radio from Larry so I can test it out then. I'll let you know then how it goes.
__________________
My Online Design Studio and Shop!

http://www.shapeways.com/shops/UID

http://www.howfastareyou.com

SUPPORT LBR!!!
(Local Basement Racing)
imxlr8ed is offline   Reply With Quote
Old 2008.07.28, 05:16 PM   #10
Old Crow
Old Crow Racing
 
Old Crow's Avatar
 
Join Date: Sep 2004
Location: N.E. Pennsylvania
Posts: 617
Ok, thanks. Guess it will be a learning experiance with the new boards.
Old Crow is offline   Reply With Quote
Old 2008.07.29, 08:54 PM   #11
TheRinger
THATS HOW I ROLL
 
TheRinger's Avatar
 
Join Date: Dec 2006
Location: Spotsylvania VA
Posts: 1,128
What if U were wearing a static wrist strap? Would that keep U and what U R holding grounded?
TheRinger is offline   Reply With Quote
Old 2008.08.04, 08:33 PM   #12
TheRinger
THATS HOW I ROLL
 
TheRinger's Avatar
 
Join Date: Dec 2006
Location: Spotsylvania VA
Posts: 1,128
Well I installed a 2x3 fet stack of 4562's on the same board and it works using a hakko ESD safe soldering station, static mat with wrist strap. All I can come up with is that the original fets I was going 2 install that I dropped on the carpet floor got zapped by static electricity or they where no good 2 begin with.

Last edited by TheRinger; 2008.08.04 at 08:36 PM.
TheRinger is offline   Reply With Quote
Old 2008.08.04, 08:54 PM   #13
imxlr8ed
Registered User
 
imxlr8ed's Avatar
 
Join Date: Sep 2004
Location: Reading Pa.
Posts: 4,121
I guess that's possible... I've accidentally dropped fets on the carpet in the past though as well, but never had an issue. I find most of the time that if something isn't working the first time out it's usually due to a cold connection or a missed one. Starting over from square one though sometimes works better than trying to work with the ones that are already installed... guess I just try harder the second time around and maybe that's what happened for you as well here. I'm certainly interested in that station though, I might have to get one to just eliminate the chance of static issues.
__________________
My Online Design Studio and Shop!

http://www.shapeways.com/shops/UID

http://www.howfastareyou.com

SUPPORT LBR!!!
(Local Basement Racing)
imxlr8ed is offline   Reply With Quote
Old 2008.08.05, 02:22 PM   #14
benmlee
Registered User
 
Join Date: May 2006
Location: Los Angeles
Posts: 375
The number 4 pin on the FET must be connected to the board before you apply any power to the board. Otherwise, the FET will short out and fry as soon as you turn on the board without even running the car.
Use a ohm meter or look carefully to make sure the pin is soldered to the board. Just because there are some solder on the pin does not mean there is a connection. Sometimes solder tend to stick to the pin, and not touch the board.

See the last paragraph on this page:

http://mini-z.home.att.net/FETInstall.htm
benmlee is offline   Reply With Quote
Old 2008.08.05, 03:37 PM   #15
imxlr8ed
Registered User
 
imxlr8ed's Avatar
 
Join Date: Sep 2004
Location: Reading Pa.
Posts: 4,121
Wow... I didn't know that one! Thanks for the tip!
__________________
My Online Design Studio and Shop!

http://www.shapeways.com/shops/UID

http://www.howfastareyou.com

SUPPORT LBR!!!
(Local Basement Racing)
imxlr8ed is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MR-02 PCB FET Upgrade Problem. Hammer Mini-Z Racer MR-02 12 2007.09.17 12:55 AM
Fet Problem Again..... ub0211042 Mini-Z Science 6 2007.08.28 11:49 PM
Fet problem Miko Mini-Z Science 9 2007.06.05 12:39 AM
Problem with FET Vagabond Mini-Z Science 5 2003.06.16 09:07 AM


All times are GMT -5. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2011 Mini-ZRacer.com
Mini Inferno Sale - Up to $85 Instant Savings!
Micro-T Hop-Ups
RC18R, M18, Micro RS4, Mini-LST, TamTech-Gear, Minizilla, RC18T, RC18B, RC18MT
shop.tinyrc.com Products

more»
Tiny RC Community News
[03/22/17] MZR was on vacation, didn't... : All kidding aside, the host experienced a bit of a server meltdown last week and efforts to restore the site to a new server took longer than anticipated. The current server is temporary until - more»
[11/25/15] Did You Hear? Our Black... : Hey Racers,
We're getting started a bit early with our Black Friday sale this year.  Generally we're not supporters of retailers opening early on Thanksgiving, but in our case, we're - more»
[06/30/15] shop.tinyrc.com: Have You... : Hey All! Just a quick reminder to everyone that we post all of our shop.tinyrc.com Newletters here on the MZR Forum. If for some reason you miss them in your email inbox, you can always see the - more»
Mini-Z, Mini-Z Racer, MR-02, MA-010
M18, M18T, RC18T, Mini-LST, Mini-T, Micro RS4, XRay, 1/18, 18th scale
XMODS, XMOD, Micro Flight, ZipZaps, ZipZaps SE, Bit Char-G, MicroSizers, TTTT, Plantraco Desktop Rover, SuperSlicks, Digi Q
Mini Inferno, Mini Inferno ST, half EIGHT, 1/16, 16th scale
Epoch, Indoor Racer, 1/43, 43rd scale
E-Savage, eSavage, eZilla, e-Zilla, HPI
Robots, Bots, Bipeds, Wheeled, Manoi, Roomba, NXT, Lego, Hacking
Crawling, Crawlers, Micro, RC, Losi Mini-Rock Crawler, Duratrax Cliff Climber
Kyosho Minium, Caliber 120, Minium Forums
Mini-Z Hop-Ups, Mini-Z Parts, Mini Inferno Hop-Ups, Mini Inferno Parts, M18 Hop-Ups, M18 Parts