Mini-Z, Kyosho Mini-Z Racer, MR-03, MR-02, MA-010, Forums, News, Pictures, Parts, and Shop - Mini-ZRacer.com
Forums, Mini-Z, MiniZ, Kyosho Mini-Z, Kyosho MiniZ, Kyosho Mini-Z Racer
Mini-Z Hop-Ups, Mini-Z Parts, MiniZ Hop-Ups, MiniZ Parts, Kyosho Mini-Z Hop-Ups, Kyosho Mini-Z Parts, Kyosho MiniZ Hop-Ups, Kyosho MiniZ Parts, Kyosho Mini-Z Racer Hop-Ups, Racer Kyosho Mini-Z Parts
Old 2012.02.20, 06:16 PM   #1
pinwc4
Registered User
 
pinwc4's Avatar
 
Join Date: Aug 2005
Posts: 913
Flip Side Racing 12.03 test build

I am releasing a test build that I would like some people to try and report back to me any issues. I have changed enough internally that I want more testing done before I release it to the general public.

Starting with this release I am changing my version numbers to be the year followed by the release number. This makes more sense with the incremental builds that I continue to release.

You can download version 12.03 from here:

Windows Zip File
Windows Installer
Mac Zip File

Some of the key changes are the following:
  • You can edit racers during a practice race or Free Play. Be very careful with this. For example if you enable a different racer with a duplicate transponder that new racer will get the laps while the existing racer will no longer get laps.
  • No longer need to set max racers, it is always 24.
  • The race screen does not show empty racers anymore, it will only display racers in the race
  • You can define individual racer colors instead of slot colors. Enable this on the General Config. screen and then define the racer colors in Edit Racers.
  • Multiple copies of the software can be ran at once, make sure to install the copies to different directories to prevent conflicts
  • The window can be resized smaller, 400x300 is the smallest size though this cuts off controls
  • Row height will be changed automatically if all racers do not fit on the screen. The row height setting now just controls the default
  • The email function filters out non-printable characters as those can create problems with the emails sent
  • Windows graphics now use the newer GDI+ graphics library, this might cause problems with Windows 2000 and older systems
  • Added none to the make menu on the edit racers screen to fix the behaviour if you click a racer with a make and then click one without, it will now default back to none instead of the previous racers make
  • Errors in manually edited xml files no longer send me a crash report they just give the user a warning
  • When a racer is first added to a race they are put in last place instead of first place for their initial lap
  • Lowered audio priority

Please test this release and let me know if you do or do not run into problems. I would like some people to verify functionality or identify issues so I can do any needed fixes/updates before this is released to the public.

Also if you do not like the implementation of some of these changes such as emptying the race screen, row space, racer colors etc. please give me input on a better approach.

As always your help is appreciated

Last edited by pinwc4; 2012.02.28 at 10:30 PM.
pinwc4 is offline   Reply With Quote
Old 2012.02.21, 05:45 AM   #2
Racer-HH
Registered User
 
Racer-HH's Avatar
 
Join Date: Feb 2008
Posts: 197
I think the new features are positive and will improve overall usability and handling. Personally I see no downside to the changes.
I will download the test version and test it in an event tomorrow evening. Hopefully everything works fine as usual.
__________________
[ my RCs: dNaNo & Mini-Z: MB-010 VE * MC-01 * MF-015 VE Pro * MR-03 VE Pro ]
[ my TX: EX-6 ]
[ my Youtube-Channel: RacersVideos ]
Racer-HH is offline   Reply With Quote
Old 2012.02.21, 09:50 AM   #3
RFick73
N.E.R.D.
 
RFick73's Avatar
 
Join Date: Jan 2010
Location: Surrey, B.C., Canada
Posts: 401
I'll also be trying it out tomorrow at a very small GTG seeing I was having half those issues.

Oh, and sorry about all those e-mails as I was configuring the race.xml file!
If I had known it was going to e-mail you, I would have disconnected from the internet! =/

Thank you for all the time you put into this program, I know it's just a hobby for you.

But we all appreciate it!
__________________
-=MR-03: VE-Eco (Stock) 98mm Pearl Yellow Lamborghini Murcielago LP670-4 SV | VE (Mod) 98mm Yellow Ferrari 458 Italia GT2=-
-=
MA-020 AWD VE Custom Nissan GT-R GT500 2008=-
-=MA-015 Custom Citreon DS3 WRC 2011=-
-=
F1 Jordon Honda EJ11 2001 Jarno Trulli "Bitten Heroes" #12=-
*EX-10 Helios*
Website: BC Mini-Z Club
RFick73 is offline   Reply With Quote
Old 2012.02.21, 10:13 PM   #4
pinwc4
Registered User
 
pinwc4's Avatar
 
Join Date: Aug 2005
Posts: 913
Quote:
Originally Posted by Racer-HH View Post
I think the new features are positive and will improve overall usability and handling. Personally I see no downside to the changes.
Yeah, the usability changes are what always concerns me. I like to get feedback in case maybe the way I am thinking things should work does not line up with everyone else.

But most of the usability changes in this case were getting rid of some leftover behaviors on how the program used to operate when you had to manually add each racer to a race.

Quote:
Originally Posted by RFick73 View Post
Oh, and sorry about all those e-mails as I was configuring the race.xml file!
If I had known it was going to e-mail you, I would have disconnected from the internet! =/
No need to be sorry. I wanted the software to submit any exceptions that occur and it was not emailing me crash reports. Instead I made a quick little web app with a database that the software submits the reports to. So I periodically check the latest errors recorded in the database and knew to just filter out anything that said XML parser related errors.
pinwc4 is offline   Reply With Quote
Old 2012.02.22, 04:36 AM   #5
Racer-HH
Registered User
 
Racer-HH's Avatar
 
Join Date: Feb 2008
Posts: 197
Downloaded and installed the beta over the current 0.76 without problems. First impressions are positive - all changes are available as described. No errors occured with first test laps.
Today we will have a race event with 5 drivers, so tomorrow I can give you more feedback.
__________________
[ my RCs: dNaNo & Mini-Z: MB-010 VE * MC-01 * MF-015 VE Pro * MR-03 VE Pro ]
[ my TX: EX-6 ]
[ my Youtube-Channel: RacersVideos ]
Racer-HH is offline   Reply With Quote
Old 2012.02.23, 03:24 AM   #6
Racer-HH
Registered User
 
Racer-HH's Avatar
 
Join Date: Feb 2008
Posts: 197
Sorry to report this, but we had several issues yesterday I'd like to address.

EDIT RACERS
1) I had to change an email-address; in the respective field the change was saved and shown. The report nevertheless was send to the old address.
2) One racer had his name also in the SPEAK field. I tried to remove it, but after deleting and saving it still showed up. (this is no real issue, just an uncommon behavior)

RACE SREEN
1) When starting a session, sometimes the starting horn sound was not played, the countdown itself (3, 2, 1) worked fine though. In a rough estimation only 5 out 8 times the horn sounded. I also like to add, that if I select a countdown from for example 5, the first number annouced via voice is always one less, in this example 4. This was also in the previous versions.
2) There seems to be a delay after the first crossing of the counter and showing the racer on the screen compared to 0.76 where it was nearly the same time. The delay is sometimes only 1-2 secs, but sometimes up to 7-8 secs.
3) When the racers appears the first time only the picture and the time was shown. No rank, no name. After 5-10 laps (7-8 secs average) rank and name where suddenly there. Lap count was correct and name was announced for best laps correctly, even when not showing.

If you need further details please let me know. Hope you can allocate the bugs and fix them. (Systems: Win XP SP3, Kyosho IC Tag)
__________________
[ my RCs: dNaNo & Mini-Z: MB-010 VE * MC-01 * MF-015 VE Pro * MR-03 VE Pro ]
[ my TX: EX-6 ]
[ my Youtube-Channel: RacersVideos ]
Racer-HH is offline   Reply With Quote
Old 2012.02.23, 11:32 AM   #7
RFick73
N.E.R.D.
 
RFick73's Avatar
 
Join Date: Jan 2010
Location: Surrey, B.C., Canada
Posts: 401
I am also seeing issues as well with the Racers names.

It seems most of the times I started a new race, it took two laps to show the users name & picture.
After it saw the transponder through the loop it would place up only timing info, then a lap later it would usually add the name.
Not a biggie, but sometimes it took longer than that or it didn't happen at all.

See screen captures I uploaded here:
http://mini-zracer.com/mini-zgallery...&size=big&cat=
& here:
http://mini-zracer.com/mini-zgallery...&size=big&cat=

As a side note, it was originally REALLY bad, but we noticed we somehow were running two copies of the software.
IF it's possible, maybe adding a toggle option in the settings window to allow, or disallow multiple windows to be opened and having it unchecked as default.

We also experienced a few missed laps but it only seemed to be for one racer, so we will have to look into that.
We only had three of us and we only really ran it for like 20-30 mins as we were doing a lot of wrenching.

Hopefully I'll have more track time soon again, if not, we have a GTG with about 12+ guys scheduled for the 4th of next month so your sure to hear from me then.

BTW, my E-Mail issues seem to be fixed now as it sent out the Race Stats perfectly after each Timed Practice.

That's all from me for now.
__________________
-=MR-03: VE-Eco (Stock) 98mm Pearl Yellow Lamborghini Murcielago LP670-4 SV | VE (Mod) 98mm Yellow Ferrari 458 Italia GT2=-
-=
MA-020 AWD VE Custom Nissan GT-R GT500 2008=-
-=MA-015 Custom Citreon DS3 WRC 2011=-
-=
F1 Jordon Honda EJ11 2001 Jarno Trulli "Bitten Heroes" #12=-
*EX-10 Helios*
Website: BC Mini-Z Club
RFick73 is offline   Reply With Quote
Old 2012.02.23, 12:53 PM   #8
RFick73
N.E.R.D.
 
RFick73's Avatar
 
Join Date: Jan 2010
Location: Surrey, B.C., Canada
Posts: 401
BTW Racer-HH,

The Countdown actually starting one lower than what you set it for, that is something I worked around a while back, but it is still an issue...

I have it start at 6, and well, it starts speaking at 5. Issue bandaided. =/
__________________
-=MR-03: VE-Eco (Stock) 98mm Pearl Yellow Lamborghini Murcielago LP670-4 SV | VE (Mod) 98mm Yellow Ferrari 458 Italia GT2=-
-=
MA-020 AWD VE Custom Nissan GT-R GT500 2008=-
-=MA-015 Custom Citreon DS3 WRC 2011=-
-=
F1 Jordon Honda EJ11 2001 Jarno Trulli "Bitten Heroes" #12=-
*EX-10 Helios*
Website: BC Mini-Z Club
RFick73 is offline   Reply With Quote
Old 2012.02.23, 02:29 PM   #9
Racer-HH
Registered User
 
Racer-HH's Avatar
 
Join Date: Feb 2008
Posts: 197
Actually this is the work around I use too. I just wanzed to address this issue together with my new findings.
__________________
[ my RCs: dNaNo & Mini-Z: MB-010 VE * MC-01 * MF-015 VE Pro * MR-03 VE Pro ]
[ my TX: EX-6 ]
[ my Youtube-Channel: RacersVideos ]
Racer-HH is offline   Reply With Quote
Old 2012.02.24, 12:59 PM   #10
pinwc4
Registered User
 
pinwc4's Avatar
 
Join Date: Aug 2005
Posts: 913
Thanks for checking this and giving feedback. I had expected the graphic changes to impact Windows 2000 some but not XP. I have updated the code and think I have it taken care of now. Plus I added the code back to prevent multiple copies from running and fixed a couple other things.

You can download version 12.03 from here:

Windows Zip File
Windows Installer

Last edited by pinwc4; 2012.02.28 at 10:19 PM.
pinwc4 is offline   Reply With Quote
Old 2012.02.25, 02:59 PM   #11
Racer-HH
Registered User
 
Racer-HH's Avatar
 
Join Date: Feb 2008
Posts: 197
Thanks for the update. You fixed every single bug I reported with 12.02. The current beta is now a big improvement to 0.76. Well done!
__________________
[ my RCs: dNaNo & Mini-Z: MB-010 VE * MC-01 * MF-015 VE Pro * MR-03 VE Pro ]
[ my TX: EX-6 ]
[ my Youtube-Channel: RacersVideos ]
Racer-HH is offline   Reply With Quote
Old 2012.02.27, 10:39 PM   #12
cmenard
Registered User
 
Join Date: Feb 2012
Posts: 7
The new version is really nice. The only problem I have to report is the starting horn never sounds. The countdown just ends at one. Also noticed that laps used to beep and announce times. That doesn't seem to be the case now.
cmenard is offline   Reply With Quote
Old 2012.02.28, 03:25 PM   #13
pinwc4
Registered User
 
pinwc4's Avatar
 
Join Date: Aug 2005
Posts: 913
Quote:
Originally Posted by cmenard View Post
The new version is really nice. The only problem I have to report is the starting horn never sounds. The countdown just ends at one. Also noticed that laps used to beep and announce times. That doesn't seem to be the case now.
If you are using Windows you will want to check your sound mixer. I have had a couple of people encounter this and in each cause the Wave audio device volume was turned down even though the main volume was turned up. In Windows the Horn and Beeps are handled by a differently audio device than the speech.

To check this on Windows XP you need to double click the speaker icon on your start bar. In Windows 7 you need to single click it then click the word mixer. When the mixer comes up make sure the volume for the Wave device is turned up. It might be named something different on Windows 7.

If that does or does not take care of the problem please let me know.
pinwc4 is offline   Reply With Quote
Old 2012.02.28, 05:45 PM   #14
cmenard
Registered User
 
Join Date: Feb 2012
Posts: 7
It is running on Win7. Version 0.76 works fine but not the last beta. No starting horn or finish horn. The volume levels are all correct. Any other things to try? Thanks for the response.
cmenard is offline   Reply With Quote
Old 2012.02.28, 07:16 PM   #15
pinwc4
Registered User
 
pinwc4's Avatar
 
Join Date: Aug 2005
Posts: 913
Quote:
Originally Posted by cmenard View Post
It is running on Win7. Version 0.76 works fine but not the last beta. No starting horn or finish horn. The volume levels are all correct. Any other things to try? Thanks for the response.
One more thing that you can test. From within the program go to the General Config. screen. On this screen click Manage Themes. It is a button on the right side of the screen about in the middle. This will open up a new window. On this window select the theme you are using to load it in the theme editor. Then click on the sounds tab. On this tab you can try to play the sounds individually.

Try that and let me know if you can hear sounds or not then.

If not then my next question is did you use the installer or the zip file? You might try running the application from a different directory such as off your desktop. For the sound effects the program has to create temporary files, maybe this is failing. Windows 7 got a lot stricter about directory permissions, I have the installer change permissions to help with this.
pinwc4 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 0.75 of Flip Side Racing software released pinwc4 Flip Side 14 2011.11.28 04:03 AM
Version 0.64 of Flip Side Racing software available pinwc4 Flip Side 3 2011.06.28 11:38 PM
PN Racing NASCAR Motor Mount rharris Parts and Hop-ups 0 2007.05.07 06:07 PM
Getting out of Mini-Z racing.... PD2 Miscellaneous Discussion 10 2006.01.19 09:35 PM
Pn Racing Side Damper set j_rock84 Parts and Hop-ups 2 2004.11.17 12:12 PM


All times are GMT -5. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©2011 Mini-ZRacer.com
Mini Inferno Sale - Up to $85 Instant Savings!
Micro-T Hop-Ups
RC18R, M18, Micro RS4, Mini-LST, TamTech-Gear, Minizilla, RC18T, RC18B, RC18MT
shop.tinyrc.com Products

more»
Tiny RC Community News
[03/22/17] MZR was on vacation, didn't... : All kidding aside, the host experienced a bit of a server meltdown last week and efforts to restore the site to a new server took longer than anticipated. The current server is temporary until - more»
[11/25/15] Did You Hear? Our Black... : Hey Racers,
We're getting started a bit early with our Black Friday sale this year.  Generally we're not supporters of retailers opening early on Thanksgiving, but in our case, we're - more»
[06/30/15] shop.tinyrc.com: Have You... : Hey All! Just a quick reminder to everyone that we post all of our shop.tinyrc.com Newletters here on the MZR Forum. If for some reason you miss them in your email inbox, you can always see the - more»
Mini-Z, Mini-Z Racer, MR-02, MA-010
M18, M18T, RC18T, Mini-LST, Mini-T, Micro RS4, XRay, 1/18, 18th scale
XMODS, XMOD, Micro Flight, ZipZaps, ZipZaps SE, Bit Char-G, MicroSizers, TTTT, Plantraco Desktop Rover, SuperSlicks, Digi Q
Mini Inferno, Mini Inferno ST, half EIGHT, 1/16, 16th scale
Epoch, Indoor Racer, 1/43, 43rd scale
E-Savage, eSavage, eZilla, e-Zilla, HPI
Robots, Bots, Bipeds, Wheeled, Manoi, Roomba, NXT, Lego, Hacking
Crawling, Crawlers, Micro, RC, Losi Mini-Rock Crawler, Duratrax Cliff Climber
Kyosho Minium, Caliber 120, Minium Forums
Mini-Z Hop-Ups, Mini-Z Parts, Mini Inferno Hop-Ups, Mini Inferno Parts, M18 Hop-Ups, M18 Parts