Mini-Z, Kyosho Mini-Z Racer, MR-03, MR-02, MA-010, Forums, News, Pictures, Parts, and Shop - Mini-ZRacer.com
Forums, Mini-Z, MiniZ, Kyosho Mini-Z, Kyosho MiniZ, Kyosho Mini-Z Racer
Mini-Z Hop-Ups, Mini-Z Parts, MiniZ Hop-Ups, MiniZ Parts, Kyosho Mini-Z Hop-Ups, Kyosho Mini-Z Parts, Kyosho MiniZ Hop-Ups, Kyosho MiniZ Parts, Kyosho Mini-Z Racer Hop-Ups, Racer Kyosho Mini-Z Parts
Old 2015.07.04, 02:13 AM   #1
mini-cam
PDXminiz.com
 
mini-cam's Avatar
 
Join Date: Dec 2014
Location: Gresham, OR
Posts: 22
Speech does not work

I can not get the Speech option to work. Is this not a working feature with Windows 7? Tried another PC and get the same error. When checking the speech box I get "Error Preparando WAV Para Posiciones : Floating point division by zero"

None of voice files play only the sound files.

Is there a fix or a patch for this to work? Other than speech the software works great!
mini-cam is offline   Reply With Quote
Old 2015.07.05, 02:49 PM   #2
zround
Registered User
 
Join Date: Jul 2009
Location: Madrid (Spain)
Posts: 252
Send a message via Skype™ to zround
That is a warning. There was not possible to generate cache files but it shouldn't let unusable the voice system.

Once the voice is selected, can you test it? (enter a text and click on "listen" button). Or nothing works?
zround is offline   Reply With Quote
Old 2015.07.05, 08:04 PM   #3
mini-cam
PDXminiz.com
 
mini-cam's Avatar
 
Join Date: Dec 2014
Location: Gresham, OR
Posts: 22
Quote:
Originally Posted by zround View Post
That is a warning. There was not possible to generate cache files but it shouldn't let unusable the voice system.

Once the voice is selected, can you test it? (enter a text and click on "listen" button). Or nothing works?
Nothing I type in the box can be heard. All the sounds work during the race. Just not the voice prompts. On the champion manager I can type words in that box and hear speech fine. Just not the scoring screen.

Last edited by mini-cam; 2015.07.07 at 02:27 AM.
mini-cam is offline   Reply With Quote
Old 2015.07.08, 05:21 PM   #4
zround
Registered User
 
Join Date: Jul 2009
Location: Madrid (Spain)
Posts: 252
Send a message via Skype™ to zround
Quote:
Originally Posted by mini-cam View Post
Nothing I type in the box can be heard. All the sounds work during the race. Just not the voice prompts. On the champion manager I can type words in that box and hear speech fine. Just not the scoring screen.
OK. Let me make some tests.

I'd like to reproduce your environment. Have you installed the software under "program files" or it is a custom folder?

Has your windows user "administration" privileges?
zround is offline   Reply With Quote
Old 2015.07.08, 06:03 PM   #5
mini-cam
PDXminiz.com
 
mini-cam's Avatar
 
Join Date: Dec 2014
Location: Gresham, OR
Posts: 22
Thanks

Quote:
Originally Posted by zround View Post
OK. Let me make some tests.

I'd like to reproduce your environment. Have you installed the software under "program files" or it is a custom folder?

Has your windows user "administration" privileges?

Thanks for your help. On the laptop we use for the club it is saved in the documents folder. I might have a problem with my Norton Virus software. Last night I ran some practice races and noticed now some of the sound wave files have been removed and the track builder software was killed. Tonight I will try and remove the software, reinstall, and make sure Norton accepts all of the software.

Really exited for our club to try and use the software for our races. We want the have a points series race soon and this software looks like it will make is real easy to do.
mini-cam is offline   Reply With Quote
Old 2015.07.26, 02:00 PM   #6
zround
Registered User
 
Join Date: Jul 2009
Location: Madrid (Spain)
Posts: 252
Send a message via Skype™ to zround
Thank you for the feedback. Enjoy ZRound!
zround is offline   Reply With Quote
Old 2015.11.04, 10:58 PM   #7
Thorvald
Registered User
 
Thorvald's Avatar
 
Join Date: Nov 2015
Location: Ontario, Canada
Posts: 61
Interesting, I just installed ZRound to try it tonight with my Trackmate setup and same issue here with Windows 7. I get the error you do and no speech.

However Flipside and the default Trackmate software work fine with speech.

The test button does not say anything when pressed (Microsoft Anna selected and some text entered into the text box).
Thorvald is offline   Reply With Quote
Old 2015.11.04, 11:24 PM   #8
Thorvald
Registered User
 
Thorvald's Avatar
 
Join Date: Nov 2015
Location: Ontario, Canada
Posts: 61
Just an update to this, used "narrator" to verify speech api is working fine.

The error message occurs when we enable SAPI, as soon as we uncheck and then check the box for SAPI 5.1, I get the error:

"Error Preparando WAV Para Posiciones : Floating point division by zero"

Para Posiciones is "To Position" or "For Position" is it not?


Any ideas?

Thanks
Tim

P.S. latest version, just downloaded tonight.
Thorvald is offline   Reply With Quote
Old 2015.11.30, 06:49 PM   #9
Thorvald
Registered User
 
Thorvald's Avatar
 
Join Date: Nov 2015
Location: Ontario, Canada
Posts: 61
I was able to fix mine through a re-install and just left the voice section "blank". It just worked fine.
Thorvald is offline   Reply With Quote
Old 2015.11.30, 07:23 PM   #10
zround
Registered User
 
Join Date: Jul 2009
Location: Madrid (Spain)
Posts: 252
Send a message via Skype™ to zround
Quote:
Originally Posted by Thorvald View Post
I was able to fix mine through a re-install and just left the voice section "blank". It just worked fine.
Hi, I've received the same issue on my mail. I will receive soon (I hope) a debug trace file to see what could happen.

I used Win7 (8, 8.1 and now 10) with voices and it always worked.

I'll keep you informed. Regards.
zround is offline   Reply With Quote
Old 2015.11.30, 09:15 PM   #11
Thorvald
Registered User
 
Thorvald's Avatar
 
Join Date: Nov 2015
Location: Ontario, Canada
Posts: 61
Sounds good, if you need any more debug info just ask.

My setup will re-produce the reported error as soon as I manually select a voice.

Cheers
Tim
Thorvald is offline   Reply With Quote
Old 2015.12.07, 12:22 PM   #12
zround
Registered User
 
Join Date: Jul 2009
Location: Madrid (Spain)
Posts: 252
Send a message via Skype™ to zround
Quote:
Originally Posted by Thorvald View Post
Sounds good, if you need any more debug info just ask.

My setup will re-produce the reported error as soon as I manually select a voice.

Cheers
Tim

I've been working on the SAPI interface and it seems the issue has been solved. Unfortunatelly I don't know what causes the issue and I've not been able to reproduce it in any of my environments.

Please contact to me by mail in order to send you a special build for testing.

Best regards,

Jesus.
zround is offline   Reply With Quote
Reply

Bookmarks

Tags
zround speech

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speech translations pinwc4 Flip Side 0 2010.01.05 08:30 PM
can a 3pk module work with a Ko Propo EX-I UR? SPANKY Transmitters, Receivers and Crystals 0 2009.08.30 09:10 AM
Kyosho motor spacers do not work w aftermarket motors? ProfoxCG Mini-Z AWD MA-010, MA-015 5 2008.12.04 11:22 PM
Will the atomic z2 motor work with a spy esc? minittrackmann Motor Tech 2 2007.06.23 03:42 PM
my car doesnt work jrmini Beginner Questions 1 2001.12.31 04:07 PM


All times are GMT -5. The time now is 12:13 AM.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2011 Mini-ZRacer.com
Mini Inferno Sale - Up to $85 Instant Savings!
Micro-T Hop-Ups
RC18R, M18, Micro RS4, Mini-LST, TamTech-Gear, Minizilla, RC18T, RC18B, RC18MT
shop.tinyrc.com Products

more»
Tiny RC Community News
[03/22/17] MZR was on vacation, didn't... : All kidding aside, the host experienced a bit of a server meltdown last week and efforts to restore the site to a new server took longer than anticipated. The current server is temporary until - more»
[11/25/15] Did You Hear? Our Black... : Hey Racers,
We're getting started a bit early with our Black Friday sale this year.  Generally we're not supporters of retailers opening early on Thanksgiving, but in our case, we're - more»
[06/30/15] shop.tinyrc.com: Have You... : Hey All! Just a quick reminder to everyone that we post all of our shop.tinyrc.com Newletters here on the MZR Forum. If for some reason you miss them in your email inbox, you can always see the - more»
Mini-Z, Mini-Z Racer, MR-02, MA-010
M18, M18T, RC18T, Mini-LST, Mini-T, Micro RS4, XRay, 1/18, 18th scale
XMODS, XMOD, Micro Flight, ZipZaps, ZipZaps SE, Bit Char-G, MicroSizers, TTTT, Plantraco Desktop Rover, SuperSlicks, Digi Q
Mini Inferno, Mini Inferno ST, half EIGHT, 1/16, 16th scale
Epoch, Indoor Racer, 1/43, 43rd scale
E-Savage, eSavage, eZilla, e-Zilla, HPI
Robots, Bots, Bipeds, Wheeled, Manoi, Roomba, NXT, Lego, Hacking
Crawling, Crawlers, Micro, RC, Losi Mini-Rock Crawler, Duratrax Cliff Climber
Kyosho Minium, Caliber 120, Minium Forums
Mini-Z Hop-Ups, Mini-Z Parts, Mini Inferno Hop-Ups, Mini Inferno Parts, M18 Hop-Ups, M18 Parts